Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Вы посетили магазин и купили 10 видов товара. В таблицу Т[1:10] вы записали количество купленного товара каждого вида

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Вы посетили магазин и купили 10 видов товара. В таблицу Т[1:10] вы записали количество купленного товара каждого вида. В таблицу C[1:10] записали цены единиц каждого вида товара соответственно. Составьте алгоритм вычисления общей стоимости всех покупок.    
алг Общая стоимость
вещ таб Т[1:10], C[1:10]
цел I, вещ AllPrice
нач
AllPrice:=0
для I от 1 до 10 шаг 1 повторять
нц
   вывод "I, " товар"
   вывод "Количество товара:"
   ввод T[I]
   вывод "Цена за единицу товара:"
   ввод C[I]
   AllPrice:=AllPrice + T[I] * C[I]
кц
вывод "Общая стоимость покупок = ", AllPrice, " руб."
кон