Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Для тех же исходных данных, что рассматриваются в параграфе, со ставьте алгоритм, в котором вычисляются четыре величины

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Для тех же исходных данных, что рассматриваются в параграфе, со ставьте алгоритм, в котором вычисляются четыре величины: средние температуры зимних, весенних, летних, осенних месяцев.    
алг Средняя температура
вещ таб Т[1:12]
цел I, вещ Twinter, Tspring, Tsummer, Tautumn
нач
для I от 1 до 12 шаг 1 повторять
нц
   вывод " T[", I, "]="
   ввод T[I]
кц
Twinter:= (T[12]+T[1]+T[2])/3
Tspring:= (T[3]+T[4]+T[5])/3
Tsummer:= (T[6]+T[7]+T[8])/3
Tautumn:= (T[9]+T[10]+T[11])/3
вывод "Средняя температура зимой = ", Twinter
вывод "Средняя температура весной = ", Tspring
вывод "Средняя температура летом = ", Tsummer
вывод "Средняя температура осенью = ", Tautumn
кон