Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Самостоятельно придумайте примеры данных, которые можно организовать в виде массива

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Самостоятельно придумайте примеры данных, которые можно организовать в виде массива. В каждом примере отметьте: каким именем можно обозначить массив, как пронумеровать его элементы, какой тип будет иметь массив? Опишите массивы по правилам АЯ.    
1. Мои денежные расходы по дням недели (Имя: MyCost; Нумерация по дням недели; Тип: вещественный)
алг Мои затраты
вещ таб MyCost[1:7]
цел I
нач
   I:=1
   пока I<=7 повторять
   нц
      вывод " MyCost[", I, "]="
      ввод MyCost[I]
      I:=I+1
   кц
кон

2. Мои оценки по физике за этот месяц (Имя: FizGrade; Нумерация по дням месяца; Тип: целый)
алг Физика
цел таб FizGrade[1:30]
цел I
нач
   I:=1
   пока I<=30 повторять
   нц
      вывод " FizGrade[", I, "]="
      ввод FizGrade[I]
      I:=I+1
   кц
кон