Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Дано целое число X и натуральное N. Составьте алгоритм вычисления X^N

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Дано целое число X и натуральное N. Составьте алгоритм вычисления X^N. Проверьте алгоритм трассировкой. Напишите программу на Паскале.    
алг СУММА
цел X, N, R, Z
нач
вывод «Введите X:»
ввод X
вывод «Введите N:»
ввод N
R:=1
Z:=1
пока R <= N повторять
нц
   Z:=Z*X
   R:=R+1
кц
вывод Z
кон


Program zad_8_nica;
var X, N, R, Z: integer;
begin
   write ('Введите X: ');
   read (X);
   write ('Введите N: ');
   read (N);
   R:=1;
   Z:=1;
   while (R <= N)
   do begin
      Z:=Z*X;
      R:=R+1;
   end;
   writeln ('X^N = ', Z)
end.