Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу на Паскале.    
алг СУММА
цел F, N, R
нач
   ввод N
   F:=0
   R:=0
   пока R <= N повторять
   нц
      F:=F+R
      R:=R+1
   кц
   вывод F
кон


Program zad_7_nica;
var F, N, R: integer;
begin
   write ('Введите N: ');
   read (N);
   while (R <= N)
   do begin
      F:=F+R;
      R:=R+1;
   end;
   writeln ('Сумма равна: ', F)
end.