Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Составьте алгоритм упорядочения значений трех переменных по возрастанию, т. е. при любых исходных значениях A, B, C

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Составьте алгоритм упорядочения значений трех переменных по возрастанию, т. е. при любых исходных значениях A, B, C отсортируйте их так, чтобы стало: A <= B <= C. Проверьте алгоритм трассировкой при разных вариантах значений исходных данных.    
алг Задача-9
вещ A, B, C, X
нач  
ввод A, B, C 
если A>В 
то если B>С 
   X:=A
   A:=C
   C:=X
иначе если C<А 
   то X:=A
   A:=B
   B:=C
   C:=X
   иначе X:=B
   B:=A
   A:=X 
кв
кв
иначе если C<А 

   то X:=B 
   B:=A 
   A:=C 
   C:=X 
иначе если C<В
   то X:=B 
   B:=C
   C:=X
кв
кв
кв
вывод A, B, C
кон

Трассировка при разных вариантах значений исходных данных: