Главная » Помощь в учебе » Школьные знания, ответы и решения школьных заданий » Информатика

Напишите на АЯ алгоритм вычисления y по формуле y = (1 – x^2 + 5x^4)^2

Нашли ошибку? Напишите нам
0.0/5, Голосов: 0

Учебник по Информатике 9 класс Семакин

Напишите на АЯ алгоритм вычисления y по формуле
y = (1 – x2 + 5x4)2,
где x – заданное целое число. Учтите следующие ограничения:
1) в арифметических выражениях можно использовать только операции сложения, вычитания и умножения;
2) каждое выражение может содержать только одну арифметическую операцию. Выполните трассировку алгоритма при x = 2.

алг Задание 7
цел x, y, z
нач
   ввод x
   z := x*x
   y := 1 – z
   z := z*z
   z := 5*z
   y := y + z
   y := y*y
   вывод y
кон