Задание 82. В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[ 1] — данные за понедельник, Dat[2] — данные за вторник и т. д.). Определите, что будет выведено в результате работы следующей программы, записанной на алгоритмическом языке. Запишите эту же программу на языке Паскаль.

Алгоритмический язык
алг
нач
целтаб Dat[1..7]
цел m, к
Dat[1]:=12; Dat[2]:=14
Dat[3] :=13; Dat[4] :=15
Dat[5] :=15; Dat [6]:=12
Dat[7] : =16
m: =0
нц для к от 1 до 7
если Dat[к]>14 то
m:=m+l
все
кц
вывод m
кон

Паскаль
var: Dat: array[1..7] of integer;
m, k: integet;
BEGIN
Dat[1]:=12; Dat[2]:=14;
Dat[3] :=13; Dat[4] :=15;
Dat[5] :=15; Dat [6]:=12;
Dat[7] : =16
m: =0;
for k:=1 to 7 do
if Dat[k]>14 then
m:=m+1;
writeln(m);
END.
Ответ: 3

ГДЗ: Рабочая тетрадь по Информатике 9 класс Босова