Составьте алгоритмы управления Чертёжником, после исполнения которых будут получены следующие рисунки



ГДЗ: Учебник по Информатике 6 класс Босова

Составьте алгоритмы управления Чертёжником, после исполнения которых будут получены следующие рисунки.

использовать Чертежник
алг Задача8_1
нач
   Вертикальная линия
   нц 7 раз
      Горизонтальная линия
      сместиться на вектор (0, 1)
   кц
   сместиться на вектор (6, -7)
   Вертикальная линия
кон

алг Вертикальная линия
нач
   опустить перо
   сместиться на вектор (0, 6)
   поднять перо
   сместиться на вектор (0, -6)
кон

алг Горизонтальная линия
нач
   опустить перо
   сместиться на вектор (6, 0)
   поднять перо
   сместиться на вектор (-6, 0)
кон


использовать Чертежник
алг Задача8_2
нач
   Горизонтальная линия
   нц 7 раз
      Вертикальная линия
      сместиться на вектор (1, 0)
   кц
   сместиться на вектор (-7, 6)
   Горизонтальная линия
кон

алг Вертикальная линия
нач
   опустить перо
   сместиться на вектор (0, 6)
   поднять перо
   сместиться на вектор (0, -6)
кон

алг Горизонтальная линия
нач
   опустить перо
   сместиться на вектор (6, 0)
   поднять перо
   сместиться на вектор (-6, 0)
кон


использовать Чертежник
алг Задача8_3
нач
   нц 7 раз
      Горизонтальная линия
      сместиться на вектор (0, 1)
   кц
   сместиться на вектор (0, -7)
   нц 7 раз
      Вертикальная линия
      сместиться на вектор (1, 0)
   кц
кон

алг Вертикальная линия
нач
   опустить перо
   сместиться на вектор (0, 6)
   поднять перо
   сместиться на вектор (0, -6)
кон

алг Горизонтальная линия
нач
   опустить перо
   сместиться на вектор (6, 0)
   поднять перо
   сместиться на вектор (-6, 0)
кон Нашли ошибку? Напишите нам