Придумайте свои задачи для Чертёжника



ГДЗ: Учебник по Информатике 6 класс Босова

Придумайте свои задачи для Чертёжника.
1. Нарисуйте ленточку.
Нарисуйте Ленточку в среде Чертежник
использовать Чертежник
алг Ленточка
нач
   нц 5 раз
      Рисунок
   кц
кон

алг Рисунок
нач
   опустить перо
   сместиться на вектор (2, 2)
   сместиться на вектор (2, 0)
   сместиться на вектор (-2, -2)
   сместиться на вектор (-2, 0)
   поднять перо
   сместиться на вектор (4, 2)
   опустить перо
   сместиться на вектор (1, -1)
   сместиться на вектор (-1, -1)
   сместиться на вектор (-1, 1)
   поднять перо
   сместиться на вектор (1, -1)
кон

2. Нарисуйте 3 лодки.
Нарисуйте 3 лодки в среде Чертежник
использовать Чертежник
алг Лодки
нач
   сместиться в точку (3, 3)
   нц 3 раз
      Лодка
   кц
кон

алг Лодка
нач
   опустить перо
   сместиться на вектор (0, 6)
   сместиться на вектор (2, -4)
   сместиться на вектор (-2, -2)
   сместиться на вектор (6, 0)
   сместиться на вектор (-3, -2)
   сместиться на вектор (-5, 0)
   сместиться на вектор (-2, 2)
   сместиться на вектор (4, 0)
   поднять перо
   сместиться на вектор (11, 0)
кон

3. Нарисуйте Домик.
Нарисуйте Домик в среде Чертежник
использовать Чертежник
алг Домик
нач
   сместиться в точку (2, 0)
   опустить перо
   сместиться на вектор (8, 0)
   сместиться на вектор (0, 5)
   сместиться на вектор (-8, 0)
   сместиться на вектор (0, -5)
   поднять перо
   сместиться на вектор (5, 0)
   опустить перо
   сместиться на вектор (2, 0)
   сместиться на вектор (0, 4)
   сместиться на вектор (-2, 0)
   сместиться на вектор (0, -4)
   поднять перо
   сместиться на вектор (-1, 2)
   опустить перо
   сместиться на вектор (0, 2)
   сместиться на вектор (-3, 0)
   сместиться на вектор (0, -2)
   сместиться на вектор (3, 0)
   поднять перо
   сместиться на вектор (5, 2)
   опустить перо
   сместиться на вектор (-5, 5)
   сместиться на вектор (-5, -5)
   поднять перо
   сместиться на вектор (7, 3)
   опустить перо
   сместиться на вектор (0, 1)
   сместиться на вектор (1, 0)
   сместиться на вектор (0, -2)
кон Нашли ошибку? Напишите нам