Ответы на тему Конструирование алгоритмов


Учебник по Информатике 9 класс Босова

1. Ознакомьтесь с материалами презентации к параграфу, содержащейся в электронном приложении к учебнику. Используйте эти материалы при подготовке ответов на вопросы и выполнении заданий.

Презентация: Перейти


2. Почему при решении самой сложной задачи затруднительно сразу конкретизировать все необходимые действия?

В самых сложных задачах имеются много объектов, которые имеют между собой связи. Человеку скорее всего будет невозможно построить последовательность действий, то есть алгоритм, и запомнить их.


3. Метод последовательного уточнения при построении алгоритма:

Для начала представим алгоритм в виде одного предписания - в виде постановки задачи. Если исполнитель не обучен исполнять данное предписание, то его нужно упростить до более простых предписаний, Объединив простые предписания в единую совокупность выполняемых в определенном порядке предписаний, то получают выполнение исходного задания в целом.


4. Связь между методом последовательного построения алгоритма и написание сочинения или подготовка к многодневному туристическому походу:

Общее это то, что мы в данных случаях пошагово детализируем поставленные задачи, для удобного выполнения.
К примеру, когда мы пишем сочинение, при написании лучше разделить его на три части(вступление, основная часть и заключение) и писать его последовательно, начиная со вступления и заканчивая заключением. И объединив три части, получим готовое сочинение.


5. Известен рост каждого ученика 9А класса и 9Б класса. Опишите алгоритм сравнения среднего роста учеников этих классов.




6.

использовать Робот
алг
нач

нц 10 раз
вправо
если клетка закрашена
то
вверх; закрасить
вниз; вниз; закрасить
вверх
все
кц
кон



7. Для чего нужны вспомогательные алгоритмы?

Вспомогательный алгоритм нужен тогда, когда в разных места алгоритма необходимо выполнить одну и ту же последовательность шагов обработки данных.


8. Процесс выполнения команды вызова вспомогательного алгоритма в основном алгоритме:




9.




10. Рекурсивные алгоритмы и примеры таких алгоритмов:

Рекурсивный алгоритм - это алгоритм, в котором прямо или косвенно содержится ссылка на него же как на вспомогательный алгоритм.


11.

а) использовать Робот
алг
нач

  угол
  вниз; вниз
  вправо; вправо
  угол
  вниз; вниз; вниз
  вправо
  угол
кон
алг угол
нач

  нц 5 раз
    закрасить; вправо
  кц
  нц 5 раз
    влево
  кц
  нц 4 раз
    вниз; закрасить
  кц
    вниз
  нц 5 раз
    вверх
  кц
кон

б) использовать Робот
алг
нач

  нц 3 раз
    угол
    вниз; вправо
  кц
кон
алг угол
нач

  нц 5 раз
    закрасить; вправо
  кц
  нц 5 раз
    влево
  кц
  нц 4 раз
    вниз; закрасить
  кц
    вниз
  нц 5 раз
    вверх
  кц
кон

в) использовать Робот
алг
нач

  нц 3 раз
    угол
    вниз; вправо; вправо
  кц
кон
алг угол
нач

  нц 5 раз
    закрасить; вправо
  кц
  нц 5 раз
    влево
  кц
  нц 4 раз
    вниз; закрасить
  кц
    вниз
  нц 5 раз
    вверх
  кц
кон